General Platform Outage
Incident Report for Uberflip
Postmortem

Technical Summary

At 14:14 ET on July 27, 2021 our systems reported an increase in latency to our primary database cluster due to an abnormal and significant increase in traffic. This increase outpaced our scaling capabilities, and resulted in a cascading failure that brought down the database cluster responsible for our Hub Platform.

Recovery efforts were initiated quickly once the cause was identified, however a complication during recovery extended the outage.

By 16:19 ET the Hub Platform was back online, and all systems were brought back to normal operation shortly thereafter.

Remediation efforts on our infrastructure and product performance are underway to prevent a recurrence of this issue.

Posted Aug 04, 2021 - 17:30 EDT

Resolved
This incident has been resolved.
Posted Jul 27, 2021 - 17:14 EDT
Monitoring
A fix has now been implemented and operations are returning to normal. The team will continue to monitor and further updates will be posted here.
Posted Jul 27, 2021 - 16:25 EDT
Identified
Our Engineering team has identified the issue and are currently preparing a fix. We will provide additional updates as soon as the fix has been deployed and validated.
Posted Jul 27, 2021 - 15:59 EDT
Investigating
We are currently experiencing an issue which is impacting availability of the platform. The team is investigating.
Posted Jul 27, 2021 - 14:33 EDT
This incident affected: Content experiences (Hubs, Flipbooks, Embeds), App, Integrations (Streams, CTAs), and APIs (REST, Legacy).