Partial Platform Outage

Incident Report for Uberflip

Resolved

This issue has been resolved, and Flipbooks can once again be uploaded to the platform.
Posted Aug 15, 2025 - 16:56 EDT

Investigating

We are currently experiencing an issue affecting PDF uploads to the Flipbook area of the Uberflip platform. Our development team is actively investigating the cause and working to resolve it as quickly as possible. We appreciate your patience and will provide further updates as soon as they become available.
Posted Aug 15, 2025 - 16:32 EDT
This incident affected: Content experiences (Hubs, Flipbooks, Embeds, Uberflip Analytics) and App.